Overdoze.Ru
Запомнить авторизацию  [?] | Забыли пароль? | Регистрация
Сегодня: 17 января 2018 г., 14:00:53  
Актуальные версии AVE CMS:   AVE CMS 3.0RC | AVE.CMS 2.09RC2 svn | AVE CMS 2.08 original

раскрутка сайтов
Добро пожаловать Гость!
Мы рады приветствовать вас на наших форумах. Вы должны зарегистрироваться, чтобы оставлять сообщения. Если вы уже зарегистрированы, то просто войдите используя форму для входа.
 
Пароль
Забыли пароль? | Зарегистрироваться

Форумы Пользователи Поиск по форумам Активные темы за последние 24 часа

Форумы
 cpengine 2.0 BETA // Модуль Системные блоки
        Использования [hide] в системных блоках
Использования [hide] в системных блоках

Четверг 19.05.2011, 12:14

VsOK



Пользователь
Эксперт

Всего сообщений: 378
Зарегистрировался: 26.03.2008
Как сделать чтобы можно было использовать скрытые для определенных груп блоки в системных блоках?
Вне сети Вне сети
 

Четверг 19.05.2011, 14:05

Максим



Администратор
Профессионал


Всего сообщений: 1684
Зарегистрировался: 13.02.2008
а чем $_SESSION['user_group'] не устраивает?


__________________________________________________
Кинокритик и Аквантико работают на AVE.CMS.
Реймакс, Минск
+(37544) 707-61-24
Вне сети Вне сети
 

Вторник 24.05.2011, 17:03

VsOK



Пользователь
Эксперт

Всего сообщений: 378
Зарегистрировался: 26.03.2008
Zitat
Писал: Максим
а чем $_SESSION['user_group'] не устраивает?


Спасибо. Устраивает.

Вне сети Вне сети
 

Четверг 26.05.2011, 17:34

VsOK



Пользователь
Эксперт

Всего сообщений: 378
Зарегистрировался: 26.03.2008
Не получается. Что-то делаю не так.
вставляю $group = $_SESSION['user_group']; чтобы потом использовать эту переменную для оператора if с помощью которого если группа пользователя, то выводить нужный кусок таблицы.

Но при открытии страницы где вставлен системный блок пишет выскакивает ошибка Notice: Undefined index: user_group in ......../modules/sysblock/class.sysblock.php(70) : eval()'d code on line 10
Editiert: 26.05.2011, 18:25:28
Вне сети Вне сети
 

Четверг 26.05.2011, 20:39

Максим



Администратор
Профессионал


Всего сообщений: 1684
Зарегистрировался: 13.02.2008
Ошибка говорит о том, что у тебя не 2.09 сборка. Поскольку ты не удосужился об этом сказать, совет был дан по ней. Принцип решения твоего вопроса остаётся тот же, тебе осталось подумать, на что нужно поменять user_group.


__________________________________________________
Кинокритик и Аквантико работают на AVE.CMS.
Реймакс, Минск
+(37544) 707-61-24
Вне сети Вне сети
 

Суббота 11.06.2011, 21:09

VsOK



Пользователь
Эксперт

Всего сообщений: 378
Зарегистрировался: 26.03.2008
Да ты прав сборка 2.08. здесь получается что нужно использовать $_SESSION['cp_ugroup']
Вне сети Вне сети
 

Печатать тему |  Следующая тема »
Показать
 

 

Печать страницы | Рекомендовать Сайт


рублей Яндекс.Деньгами
на счёт 41001130616963 (Разработки Overdoze.Ru)

Сибавтомастер: техобслуживание и ремонт японских автомобилей
Количство запросов к БД: 264шт. | Время генерации страницы: 0,2098